警告!WP Super Cache 缓存功能损坏!”的解决方法

汪 休 发布于 9个月前 分类:建站问题交流

出现以下问题:
“警告!WP Super Cache 缓存功能损坏!advanced-cache.php 无法加载 wp-cache-phase1.php。”

"WP_CACHE constant added to wp-config.php"

是WordPress安装了 WP Super Cache 缓存插件的用户,网站搬家迁移之后新网站生成缓存后,在进入后台的WP Super Cache 设置时出现的错误提示,原因跟网站路径变化有关。

解决方法如下:
1. 进入网站的FTP文件管理,在网站根目录下,找到 wp-config.php(WordPress网站配置文件),找到其中的如下一行代码:

require_once(ABSPATH . 'wp-settings.php');

在其之上,加入以下两行代码:

define('WP_CACHE', true);
define( 'WPCACHEHOME', '/data/www/www.www.com/wp-content/plugins/wp-super-cache/' );

把“/data/www/www.www.com/”这部分替换成自己服务器的路径。

2.如此更改完WP Super Cache的新网站路径之后,WP Super Cache 插件就可以正常运行了。

0个回复

  • 暂无回复
QR code